AWS is currently experiencing service degradation in the regions hosting BQE CORE

Incident Report for BQE CORE

Resolved

BQE CORE is now fully operational and performing normally. The performance issues experienced earlier have been resolved.

Our team has verified that services have returned to normal and will continue to closely monitor the environment to ensure continued stability.

Thank you for your patience and understanding
Posted Aug 12, 2026 - 05:42 PDT

Investigating

AWS is currently experiencing service degradation in the regions hosting BQE CORE. Users may see connection errors, timeouts, or slower than normal response times, and some may be unable to access the application.
Our team is working with AWS to assess the impact and restore normal service. We will post our next update by 05:30 AM PST

We apologize for the disruption and appreciate your patience.
Posted Aug 12, 2026 - 04:54 PDT
This incident affected: BQECORE - US, CAN & UK (CORE Front-End UI).