We are pleased to inform you that the scheduled maintenance has been successfully completed. All systems are now fully operational, and you should be able to access BQE CORE without any issues.
Thank you for your patience and understanding during this maintenance period. If you experience any further issues, please don’t hesitate to contact BQE CORE Support at support@bqe.com or call 310-602-4030.
Thank you, The BQE CORE Team
Posted May 09, 2026 - 01:31 PDT
Completed
The scheduled maintenance has been completed.
Posted May 09, 2026 - 01:30 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2026 - 21:30 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 07, 2026 - 08:08 PDT
Scheduled
We will be performing scheduled maintenance as part of a planned infrastructure modernization for the USA & UK datacenter region. During this window, access to BQE CORE will be unavailable for USA region users. The maintenance is expected to last approximately 4 hours.
We kindly request that you complete any time-sensitive work items prior to the start of this maintenance window.
Maintenance schedule start, for different time zones: Time Zone Date Time PST 08 May 2026 09:30 PM ET/EDT 09 May 2026 12:30 AM UTC 09 May 2026 04:30 AM
You can follow real-time updates on this page throughout the maintenance period. We appreciate your patience and understanding as we work to improve your experience with BQE CORE. For any questions, please contact BQE CORE Support at support@bqe.com or call 310-602-4030.
Thank you, The BQE CORE Team
Posted May 07, 2026 - 08:06 PDT
This scheduled maintenance affected: BQECORE - US, CAN & UK (Login and SSO (Single Sign-On) Services, CORE API Services, CORE Backend Services, CORE Front-End UI, CORE Reporting Services, CORE Public API Services) and Maintenance Notification (Disruption Maintenance Notices - US, CAN, UK).