The scheduled maintenance for BQE CORE has been successfully completed, and all core services are operating normally.
We will continue to monitor the platform to ensure ongoing stability and performance.
Thank you for your patience and understanding throughout the maintenance window. If you experience any issues, please contact BQE CORE Support at support@bqe.com or call +1 (310) 602-4030. Thank you, The BQE CORE Team
Posted Jul 10, 2026 - 04:55 PDT
In progress
The planned updates for BQE CORE are currently in progress as part of the scheduled maintenance window.
During this time, you may experience intermittent issues signing in to BQE CORE and occasional slower application performance while the updates are being applied.
We will continue to provide updates on this status page as maintenance progresses. Thank you for your patience and understanding.. For any questions, please contact BQE CORE Support at support@bqe.com or call 310-602-4030.
Thank you, The BQE CORE Team
Posted Jul 10, 2026 - 03:59 PDT
Scheduled
We will be performing scheduled maintenance on BQE CORE to improve platform stability, performance, and reliability. The maintenance window is expected to last approximately 3 hours
What to expect during this maintenance: During the first phase of the maintenance, you may experience intermittent issues signing in to BQE CORE. Once this phase is complete, normal access to BQE CORE will be restored, and you can continue working as usual. You may notice slightly slower performance while we complete the remaining maintenance activities.
Maintenance start times by time zone: Time Zone Date Time AEST 10 July 2026 09:00 PM MEST 10 July 2026 01:00 PM
We will post real-time updates on this status page throughout the maintenance window. We appreciate your patience and understanding as we work to enhance your experience with BQE CORE. If you have any questions, please contact BQE CORE Support at support@bqe.com or call 310-602-4030
Posted Jul 09, 2026 - 09:02 PDT
This scheduled maintenance affected: BQECORE - AUS & UAE (Login and SSO (Single Sign-On) Services, CORE API Services, CORE Backend Services, CORE Front-End UI, CORE Reporting Services, CORE Public API Services) and Maintenance Notification (Disruption Maintenance Notices - Australia, UAE).